Current time: 02-23-2018, 02:35 PM Hello There, Guest! (LoginRegister)


 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Cluster issues....
02-04-2018, 04:14 PM
Post: #1
Cluster issues....
I'm having issues with my instrument cluster. It is now off and all guages are no longer working. But every now and then they will flicker on.... I tried all the fuses and do not know where to go with it next. Also is there a section on this forum for manuals and diagrams? Thank you all for your time, I appreciate all of your experience and help.
2007 CVPI
Find all posts by this user View This User Garage
Like Post Quote this message in a reply
02-04-2018, 06:18 PM (This post was last modified: 02-04-2018 06:19 PM by BlackVic_P71.)
Post: #2
RE: Cluster issues....
For future posts, put in what car you're talking about, or at least add the car to your signature(but we can't see that on Tapatalk)
Can we assume this is a 2007 mentioned In another thread?
2006+ have cluster issues, sometimes the connector is loose, sometimes it's a ground in the kick panel, sometimes it needs a rebuild.
[Image: 7082f310-ddf0-45a9-9fc0-153a7ca0a8ce.jpg]
1989 Country Squire - needs more air
2005 CV Sport
SW full exhaust, Heinous control arms, Hawk pads, Powerslot rotors, Addco swaybars, BBK TB, Accufab plenum

Panther, Ford, Crown Victoria, Mercury, Grand Marquis, Marauder, Lincoln, Town Car, Police Interceptor, P71, CVPI, LX Sport, LX, LS, GS, Signature, Limited
Find all posts by this user View This User Garage
Like Post Quote this message in a reply



Forum Jump:


User(s) browsing this thread: 1 Guest(s)

PantherBB.com
Copyright 2012-2015 - All Rights Reserved.

Images, graphics and data contained in this forum are the properties of the contributing members, or PantherBB.com
and may not be used without expressed written consent.
PantherBB.com
is not affiliated with the Ford motor company.